Aprilia Caponord Forum  

Go Back   Aprilia Caponord Forum > Aprilia Caponord Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions

Reply
 
LinkBack Thread Tools Display Modes
Old August 10th, 2015, 12:19 AM   #1
Junior Member
 
Joined: Aug 2014
From: Mirfield
Posts: 12

I Ride: Aprilia caponord 1200
red warning light and efi light

Does anyone have any ideas about this. The red warning light and EFI light comes on. it will stay on for as long as you're riding and then when you stop and the bike has cooled down it will go off. It doesn't come on immediatley but after some time when the riding gets spirited (faster)
Doesn't seem to be much difference in performance except it runs slightly hotter and it appears as though variable valve on the exhaust is stuck open
Dick38 is offline  
Register

Welcome to the Aprilia Caponord Forum dedicated to the Aprilia Caponord.

We welcome everyone and the community is free to join so register today and become part of the Aprilia Caponord Forum family!

Old August 10th, 2015, 02:51 AM   #2
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Duncan Moffatt

Exactly the same happening on my 2015 Rally, now at Wheels of Peterborough.
Aprilia have been notified and I expect an answer Monday Afternoon or Tuesday of this week
Am extremely disappointed that this fault cannot be rectified at present, on top of which my foot/leg cooks at the high temperature emanating from the Bike
Maybe shouldn't have purchased an Italian Bike!! Love the looks, hate the problems!!
Duncan is offline  
Old August 10th, 2015, 07:02 AM   #3
Junior Member
 
Joined: Mar 2015
From: Cheslyn Hay
Posts: 6

Sounds like the servo motor has failed and the exhaust valve is fully open.
Is the exhaust note louder as that is usually a sure sign.

Desperado
desperado is offline  
Old August 10th, 2015, 08:02 AM   #4
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Hi Desperado

Thanks for that

the head of service at "Wheels of Peterborough" told me that the exhaust problem had already been investigated and that the current fault had been recorded (twice) as a "Cam-Bus" issue that cannot be narrowed down at the moment!! sounds like a bit of jargon to me, but they have been informative and helpful so far so I ought to wait for info until Tuesday evening at least,hope that this will generate some feedback and help from others with the new Caponord Rally model

Thanks
Duncan
Duncan is offline  
Old August 11th, 2015, 02:47 AM   #5
Junior Member
 
Joined: Aug 2014
From: Mirfield
Posts: 12

I Ride: Aprilia caponord 1200
Had mine in at the dealers yesterday and he's diagnosed it as the servo motor as desperado says. New one on order. Dyrons in Leeds have been great, well worth recommending, since the place where I bought it from last year Padgetts of Batley are no longer Aprilia dealers.
Apparently they refused to invest with Aprilia in decent showroom area and having a couple of demonstrators.
I for one will never darken their door again
Dick38 is offline  
Old August 11th, 2015, 02:56 AM   #6
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Thanks Dick

will try to suggest this "fix" to the service department at Wheels.
Awaiting a call back from them any time soon.
Thanks for the continued info.

Sincerely
Duncan
Duncan is offline  
Old August 11th, 2015, 05:59 PM   #7
Senior Member
 
Joined: Mar 2015
From: Brisbane Australia
Posts: 210

I Ride: Caponord 1200 touring (but I kept my CBR1100XX - to good to part with)
G'day Dick38 - That ain't normal.....but I guess you know that!

I can't offer any probable causes and hope that the dealer's mechanics resolve the issue quickly. Your Capo should just be like a Honda....stick key in, start, ride. errr once you've Locktite'd a couple of bolts.

I've read many a complaint about other brands, so a bit of 'fettling' is par for the course with most manufacturer's, unless the dealer has enthusiasm and is great with pre-delivery checks.

Hope you are back on two wheels soon!
BrisbaNord is offline  
Old August 11th, 2015, 08:55 PM   #8
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Hi Brisbanord and Dick

Dealer waiting for feedback from Aprilia, I am Capoless!!!

Have now had the bike for about 3 weeks since I bought it on 9th June, partly due to waiting for accessories to arrive, and partly due to this latest problem. That is a very poor return on my investment, and I am bitterly disappointed. If it is a part failure i.e. servo motor, it may be another couple of weeks to replace.

I have been provided with a "15" model 1000 Versys, which is running perfectly, no problems at all, which is making me wish I had stayed with my Japanese bikes.

The dealership cannot move forward as the MD is on vacation until next week, and nobody is available to discuss what to do next, I think that to be fair, they have done all they can, short of offering me my money back, which I haven't yet formally asked for.

My general advice at the moment for anybody wishing to purchase one of these Caponord Rally bikes is to wait until this problem is sorted, probably within the next month or so, or cancel your order for the moment and consider another make.
Duncan is offline  
Old August 13th, 2015, 02:35 AM   #9
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Good Morning all

Latest update

Wheels have sent for a new ADD unit under warranty, and are trying to get the bike ready for the weekend.
Fingers crossed that this solves the problem!!
I have low confidence, but will keep the Forum informed, good or bad!

Thanks for all feedback
Duncan is offline  
Old August 18th, 2015, 07:50 AM   #10
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
latest info

Hello again

Current situation

Part awaited from Aprilia-- Bike with dealer-- owner of dealership guarantees satisfaction or replacement bike, what a great offer.

Have lost my summer's riding

The Moral of this story

Buy your bike from Wheels Peterborough-- they will look after you.

Do not let your heart rule your head on a major purchase!!!
Duncan is offline  
Old August 18th, 2015, 01:25 PM   #11
Member
 
Joined: Nov 2014
From: Darlington
Posts: 50

Sorry for your problems. What I don't understand is what the ADD unit has to do with the exhaust valve? Unless I am missing something in your posts.
Rockbyter is offline  
Old August 23rd, 2015, 01:28 PM   #12
Junior Member
 
Joined: Aug 2015
From: Johannesburg
Posts: 2

Efi warning light

Hi guys, just got my bike from private seller and have experienced same issue with warning light, over heating with noisy and jiggy engine.

It seems like this fault happens quite often on this otherwise lovely piece of bike.

My one is now sitting at Aprilia Johannesburg waiting for diagnose. I would really appreciate some feedback from you guys so maybe I could give some useful info to the technicians. Italian forums also speak about a recall campaign regarding something to do with the airbox.


Happy riding✌
Dan Joburg is offline  
Old September 15th, 2015, 10:37 PM   #13
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
EFI light

Hi

received my Caponord Rally back from Wheels Peterborough.
I don't know what has been done but it has been extensive including the replacement of the ECU or parts of it, and replacement of the ADD unit and some suspension parts.

I cannot fully understand the codes on the work sheet which stayed with the delivery note of the bike but it looks like over 1K worth of new parts.

My advice
a) Shop at Wheels Peterborough, they look after you.
b) Buy the new Honda!!

I will ride the bike over the next week to see if it is fixed and report back

Very Very disappointed in this fine looking but flawed piece of equipment
Duncan is offline  
Old September 19th, 2015, 12:17 AM   #14
Senior Member
 
Joined: Mar 2015
From: Brisbane Australia
Posts: 210

I Ride: Caponord 1200 touring (but I kept my CBR1100XX - to good to part with)
G'day all, Sorry to read about problems with your mistress's - not being smug or anything but I've not had any drama's with my beautiful Travel Pack and have now clocked up 14,650kms

I truly hope all issues have been sorted, so you can enjoy your bikes. It's been a mystery why some have had such a bad run, and yet to others Capo is trouble free.

I had a ride on a 2013 TP last week (it had 20,000kms up) and it was magic! Oddly, it had OEM gearing (ie 17/42 sprockets) and I thought it was better than my younger Capo, so I hope you can get down to the task of putting enough Kms on your machines to settle them down, and be rewarded with the same smooth motoring experience I have been enjoying on my '7 month old' 2014 model.

(ps my throttle was sensitive from new, but it tamed down by 5000kms - just had to keep the revs over 4000rpm, and now at 14,650kms it is a real smoothie.....and I'm still in awe of the ADD....)...sorry I've lost my thoughts...bloody cat wants my chair..........oh that's right, bloke called idiakez posted on the AF1 forum, that he had the 17/46 Aprilia sprockets on his TP and that gave him 4000rpm in 6th gear at 100kph(similar to mine with 16/42)....I'd recommend either 16/42 or 17/46, so you can let the thing rev happily while it runs itself in over the 5000kms it needs to 'wear in' - Cheers (and when you need new tyres...check there is grease in your wheel bearings....don't assume....I found one front was dry!)

Last edited by BrisbaNord; September 19th, 2015 at 12:29 AM.
BrisbaNord is offline  
Old September 21st, 2015, 12:14 AM   #15
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Thanks

Thank you for your encouraging comments Brisanord

I look forward to having such a wonderful machine as yours clearly is and has become! I think that many people have found the machine trouble free, but there are a number of us who have not been so lucky.

As for the question on the Problem in hand regarding the EFI light

Please ask your dealership to Contact Wheels at Peterborough, The Managing Director there took an interest in the problems I was having with the Rally, and after a considerable amount of time and work put in by him, a replacement "unit" was sourced from Aprilia and fitted to the bike.

I do not, as stated previously, understand what the issue was, it was electronic, and needed dealer/manufacturer intervention.

The current situation is that I received the bike back form the dealership last week, they had worked on the bike and test ridden it for 4 weeks.

I have covered about 100 miles on it since receiving it back, so far it has remained trouble free, and very good to ride.

I can guess and contemplate what the problems may have been, but do not care, I just want it to work.

I strongly recommend that you either get your dealership to contact Aprilia or the Wheels Peterborough Aprilia dealers to ascertain their response to the problem, or you take the bike back and demand a full refund under the sale of goods legislation.

Hope that helps
Duncan is offline  
Old September 22nd, 2015, 06:52 AM   #16
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
progress report

Hi

another 100 miles clocked up, slightly more rapid progress made

The bike is performing exactly as I would have hoped

This weekend will give it a serious ride-out after which I will report back

Sincerely hope that the problem is now fixed, the bike is very comfortable,loads of rattles but rides very well indeed, power adequate, fuel consumption currently 17.1 Kms per Ltr, fair enough, engine heat between 60C and 80 C rising to 95C when stuck in solid traffic (when filtering is not appropriate) or at red light, then fan cuts in.

Can relay all info from the excellent AMP accessory talking to my iPhone, and displaying it during my ride.

Pity the bike was not like this from the off - I generally only keep bikes for 12 months, this one is no exception, looks like someone will be the recipient of a well sorted bike yet again!

Safe Riding
Regards
Duncan
Duncan is offline  
Old September 23rd, 2015, 05:41 AM   #17
Junior Member
 
Joined: Aug 2014
From: Mirfield
Posts: 12

I Ride: Aprilia caponord 1200
Red light and efi warning

Hi there
I'm still waiting for the replacement exhaust power valve electric motor. Apparently the dealer had sent insufficient information for that read text and photos to aprilia. Could they be bothered to let the dealer know? Not on your life, wankers! In the end I got fed up of waiting and complained directly to aprilia about the situation who in turn got back in touch with dealer and asked them to send info so some lazy Italian could deal with it.
Hopefully will have bike back to normal in next couple of weeks but nit holding my breath
As soon as I find a better bike to ride it's going.
Customer service is not in the vocabulary of aprilia
Dick38 is offline  
Old September 25th, 2015, 02:06 AM   #18
Junior Member
 
Joined: Jul 2015
From: Lincolnshire
Posts: 11

I Ride: Caponord Rally
Hi

HI Dick

absolutely agree with your sentiments

It has taken 3 months exactly to get my new bike up and running, Aprilia are polite, lovely, but totally incompetent people to deal with.

I do feel that the intervention of the MD at my dealer, Wheels Peterborough, solved the problem

I am really afraid that the given solution you have may not solve the problem, get rid asap is my advice.
Sorry--

My bike is running absolutely beautifully at the moment, I do hope it will continue to do so, I will keep posting to the forum to hopefully be able to be positive in the long run.

Hope you get back on the road soon

Duncan
Duncan is offline  
Old October 31st, 2015, 03:12 PM   #19
Junior Member
 
big bull's Avatar
 
Joined: Aug 2015
From: scotland uk
Posts: 4

I Ride: Cap Rally, Duc Multi 1200s Duc 916 Yam R1 big bang
Hi there, am riding a 2015 Rally I got same EFI light on after 5k miles took it to my dealer Jim Allan Motorcycles in Falkirk Scotland having experienced much same problems as u guys, hotter engine and a fluffy power delivery.
Tom there tech was onto it like a dog into burst ball, kept me fully appraised of situ and location of new module to solve the problem having fully explained all the jargon of it to me. I felt much better over it knowing personally this type of prob common in cars too.
In brief the exhaust valve cables needed to be exactly set up to the correct length, no wrong measurements as this throws light back on. Your able to hear when its ready to go when you switch on your ignition it no longer crisply bursts into life it takes a lot longer making many more little noises.
New module took a couple of weeks to come through from Italy but I was able to do another 2k in the mean time without any prob. Running it with this fault is well bearable and it comes and goes with you returning to normal for some of your journey. Strange one I know but I have new one fitted cables oiled up inside and correctly adjusted with also a new Aprilia map and its back like the first day I got my bike again. Loving it at 6'3" its great on my knees from the old sport bike days. Cant stay off it 8k in four months....
big bull is offline  
Old April 30th, 2016, 09:42 AM   #20
Junior Member
 
Joined: Apr 2016
From: Chatham Kent
Posts: 11

I Ride: CAPONORD 1200 RALLY ARMY GREEN 2015
Warning Efi light

Only had my 1200 Rally for 2 weeks and whilst riding the warning light came on. No loss of power or performance didn't notice increase in heat as mentioned on this thread. Bike at Slocombes who rang to say cable controlling the exhaust valve was defective and new one to be ordered. Clearly this light can have a number of faults but the exhaust valve does seem favourite.
Andy1200R is offline  
Reply

  Aprilia Caponord Forum > Aprilia Caponord Forum > Mechanical and Technical



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Faction and abs warning lights on Zencra Mechanical and Technical 6 May 22nd, 2017 05:52 PM
aprilia caponord add suspension red warning light correajuan Aprilia Caponord 1 January 11th, 2017 12:03 PM
Fault light on with EFI but dealer says no diagnostic fault logged Lord Brinkworth Mechanical and Technical 1 June 17th, 2014 02:26 PM


Copyright © 2012-2013 Caponord. All rights reserved.