Aprilia Caponord Forum  

Go Back   Aprilia Caponord Forum > Aprilia Caponord Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions

Reply
 
LinkBack Thread Tools Display Modes
Old May 13th, 2017, 12:06 PM   #1
Junior Member
 
Joined: May 2017
From: Yorkshire
Posts: 1

Engine rough running

I have just purchased a 2013 model and am delighted with it. But the engine does not run smoothly between 4000 and 4600 revs.when under light load I have the latest fuel mapping. The dealer advises it is simply due to the various sensor inputs conflicting and suggested simply fitting a smaller REAR sprocket to increase the revs. I do not wish to do this. Has any one else experienced this and what was the solution.
Alan is offline  
Register

Welcome to the Aprilia Caponord Forum dedicated to the Aprilia Caponord.

We welcome everyone and the community is free to join so register today and become part of the Aprilia Caponord Forum family!

Old May 14th, 2017, 03:35 AM   #2
Junior Member
 
Joined: Mar 2017
From: Croydon North
Posts: 6

I Ride: 2015 Caponord and a Road King
I own a 2015 Capo and haven't noticed any rough spots, however there is differant gear ratios that people use. I've left mine standard also. The throttle response is a bit sensitive with the fly by wire,mine has ticked over 5500km now the only issue I've had is because I removed the standard muffler. This caused a engine ECU fault which the dealer turned off..
Moose03 is offline  
Old May 18th, 2017, 05:06 AM   #3
Member
 
heinz57's Avatar
 
Joined: Oct 2016
From: surrey
Posts: 36

I Ride: Caponord Rally Raid
I haven't noticed this either, what riding mode do you notice it happenning in?
heinz57 is offline  
Old July 31st, 2017, 07:54 PM   #4
Junior Member
 
Joined: Mar 2017
From: California
Posts: 3

Running rough

Hello there I also have the same problem this is what I have done to my bike:
Purchase it New but it was a demo version with 38k miles on it 2016 green and gorgeous:
Was having a lot of problems at low RPM's taking off and trying to maneuver at low speeds. Solution, replaced exhaust with GPR Aprilia Caponord Homologated Slip-on Furore Nero Model A.58.FUNE. 318 US, Then from bluemonkeymotorsports.com get the ESE-x Exhaust Servo Eliminator
Select Model: A02. $52 US.
Install per videos in YouTube. Plenty. And the bike ran like it supposed to.
But then... The genius of me decided to install a power chord running from tail compartment to the handle bars to keep phones and gps charged at all times.... OMG ... Never ever ever connect the usb port in the fuse compartment to do this.... BIG mistake... Regardless what people say, that messed up my sensors so bad that it was causing engine to stop... Use the standard doc plug that comes with it.....More to come....
Engine still rough sometimes but it sound grrrreat!!! Hahaha
aceves2434 is offline  
Old July 31st, 2017, 07:56 PM   #5
Junior Member
 
Joined: Mar 2017
From: California
Posts: 3

Quote:
Originally Posted by heinz57 View Post
I haven't noticed this either, what riding mode do you notice it happenning in?
It happens in all modes sport touring rain, track control 123, load driver pax and luggage ... All modes, have 3 k miles testing this beauty, will keep posted
aceves2434 is offline  
Reply

  Aprilia Caponord Forum > Aprilia Caponord Forum > Mechanical and Technical


« Chain adjustment | - »

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Puig engine guards Bill barber Mechanical and Technical 3 February 7th, 2016 01:46 AM
2004 caponord engine missfiring problem Pete Stephens Mechanical and Technical 3 November 24th, 2013 09:49 AM


Copyright © 2012-2013 Caponord. All rights reserved.