Aprilia Caponord Forum  

Go Back   Aprilia Caponord Forum > Aprilia Caponord Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions

Reply
 
LinkBack Thread Tools Display Modes
Old January 6th, 2019, 08:02 PM   #1
Junior Member
 
Joined: Mar 2017
From: Croydon North
Posts: 10

I Ride: 2015 Caponord and a Road King
EFI light

Hi I have a 2015 Caponord with a constant EFI issue and flashing Suspension icon. I had the software rebooted the other day and the issue came back again.
Here is what it is doing: https://imgur.com/gallery/vvomTyo
Moose03 is offline  
Register

Welcome to the Aprilia Caponord Forum dedicated to the Aprilia Caponord.

We welcome everyone and the community is free to join so register today and become part of the Aprilia Caponord Forum family!

Old June 3rd, 2019, 04:38 PM   #2
Junior Member
 
Joined: Jun 2019
From: monterey, CA
Posts: 2

I Ride: 2007 Aprilia Caponord
Unhappy EFI light flashing

I am also currently having a problem with my EFI light.
a friend dropped the bike on its left side, and now for some reason
the EFI light flashes when I turn the key, and as a result the engine doesn't
even attempt to turn over.

I read through the MOM and there wasn't much information, I so I simply
checked the spark plugs (all fine) and disconnected/reconnected the battery.
at this point, however, I don't really know what to look for that may have
tripped the EFI indicating an abnormality.

oh, its a 2007 Caponord, the old 1000cc version.

any advice or help would be much appreciated.

best,
s
sv1000 is offline  
Old June 30th, 2019, 07:41 PM   #3
Junior Member
 
Joined: Jun 2019
From: monterey, CA
Posts: 2

I Ride: 2007 Aprilia Caponord
solution found

after I took it to my local mechanic (towed in a flatbed of course)
he ended up telling me that although I checked all the fuses
that one of them (dealing with the EFI) had shorted even though when
I took them out one by one they all looked fine.

he said that unless you have a way to see if the circuit is still in tact - which
I don't - there could be hairline fractures making the fuse look fine, but in
reality it is caput.

the last portion of the equation was that the starter solenoid was stuck.
I myself had wondered if that was a problem, so I gave it a few good whacks,
but apparently I should have removed it and then hit it quite a few times
with more force than I had originally applied.

so anyway, the blown fuse triggered the EFI light, and then once the fuse
was replaced, it turned off immediately. as a result, only leaving the
starter solenoid to be dealt with.


I hope this information helps anybody who encounters any such problem
in the future.
sv1000 is offline  
Reply

  Aprilia Caponord Forum > Aprilia Caponord Forum > Mechanical and Technical



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
red warning light and efi light Dick38 Mechanical and Technical 29 October 12th, 2016 11:58 AM


Copyright © 2012-2013 Caponord. All rights reserved.